# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"[\n]+\s+public function [a-z]+[(][a-zA-Z0-9=',]+[)]\n+\s+[{]\n(.+?)\n+\s+[}]"
test_str = ("class T\n"
"{\n"
" public function abc(dsv)\n"
" {\n"
" sdvdsv;csdcsd\n"
" sdcsdcsdc\n"
" }\n"
" \n"
" public function abc(dsv)\n"
" {\n"
" sdvdsv;csdcsd\n"
" sdcsdcsdc\n"
" }\n"
"}\n\n")
matches = re.search(regex, test_str, re.DOTALL)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.