#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?s)[\n]+\s+public function [a-z]+[(][a-zA-Z0-9=',]+[)]\n+\s+[{]\n(.+?)\n+\s+[}]"
Local $sString = "class T" & @CRLF & _
"{" & @CRLF & _
" public function abc(dsv)" & @CRLF & _
" {" & @CRLF & _
" sdvdsv;csdcsd" & @CRLF & _
" sdcsdcsdc" & @CRLF & _
" }" & @CRLF & _
" " & @CRLF & _
" public function abc(dsv)" & @CRLF & _
" {" & @CRLF & _
" sdvdsv;csdcsd" & @CRLF & _
" sdcsdcsdc" & @CRLF & _
" }" & @CRLF & _
"}" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")