re = /(?<remote>[^ ]*) - (?<user>[^ ]*) \[(?<time>[^\]]*)\] "(?<method>\S+)(?: +(?<path>[^\"]*) +\S*)?" (?<code>[^ ]*) (?<size>[^ ]*)(?: "(?<referer>[^\"]*)" "(?<agent>[^\"]*)")? (?<request_time>[^ ]*) (?<upstream_response_time>[^ ]*)/
str = '115.192.115.147 - - [04/Dec/2015:01:08:03 +0800] "GET /n
otify HTTP/1.1" 200 0 "-" "Android/19 (cynovo-par10; DRX-1.1.2-20151103-H7; root; unknown; zh_CN) com.luedongtech.kr3000/231 00:23:9e:03:49:5b" 0.004 0.004
'
# Print the match result
str.match(re) do |match|
puts match.to_s
end