use strict;
my $str = '115.192.115.147 - - [04/Dec/2015:01:08:03 +0800] "GET /n
otify HTTP/1.1" 200 0 "-" "Android/19 (cynovo-par10; DRX-1.1.2-20151103-H7; root; unknown; zh_CN) com.luedongtech.kr3000/231 00:23:9e:03:49:5b" 0.004 0.004
';
my $regex = qr/(?<remote>[^ ]*) - (?<user>[^ ]*) \[(?<time>[^\]]*)\] "(?<method>\S+)(?: +(?<path>[^\"]*) +\S*)?" (?<code>[^ ]*) (?<size>[^ ]*)(?: "(?<referer>[^\"]*)" "(?<agent>[^\"]*)")? (?<request_time>[^ ]*) (?<upstream_response_time>[^ ]*)/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}