# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(?<remote>[^ ]*) - (?<user>[^ ]*) \[(?<time>[^\]]*)\] \"(?<method>\S+)(?: +(?<path>[^\"]*) +\S*)?\" (?<code>[^ ]*) (?<size>[^ ]*)(?: \"(?<referer>[^\"]*)\" \"(?<agent>[^\"]*)\")? (?<request_time>[^ ]*) (?<upstream_response_time>[^ ]*)"
test_str = ("115.192.115.147 - - [04/Dec/2015:01:08:03 +0800] \"GET /n\n"
"otify HTTP/1.1\" 200 0 \"-\" \"Android/19 (cynovo-par10; DRX-1.1.2-20151103-H7; root; unknown; zh_CN) com.luedongtech.kr3000/231 00:23:9e:03:49:5b\" 0.004 0.004\n")
matches = re.search(regex, test_str)
if matches:
print ("Match was found at {start}-{end}: {match}".format(start = matches.start(), end = matches.end(), match = matches.group()))
for groupNum in range(0, len(matches.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = matches.start(groupNum), end = matches.end(groupNum), group = matches.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.