// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(\s[a-zA-Z]{6}[0-9]{8}\s){1}").unwrap();
let string = " sdfs sdfs FLBREV00022230 dsfsdfs sdfsf FLBREV00022234 ";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}