import Foundation
let pattern = #"(?:\+994|0)(?:51|50|55|70|77|99)[^\d]{0,2}[2-9][0-9]{2}[^\d]{0,2}[0-9]{2}[^\d]{0,2}[0-9]{2}[^\d]"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
+994509793270
0509793270
+994708769006
0708769006
+994559793270
0559793270
+994519793270
0519793270
+994999793270
0999793270
+994779793270
0779793270
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)