const regex = new RegExp('(?:\\+994|0)(?:51|50|55|70|77|99)[^\\d]{0,2}[2-9][0-9]{2}[^\\d]{0,2}[0-9]{2}[^\\d]{0,2}[0-9]{2}[^\\d]', 'gm')
const str = `
+994509793270
0509793270
+994708769006
0708769006
+994559793270
0559793270
+994519793270
0519793270
+994999793270
0999793270
+994779793270
0779793270
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}