import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?:\\+994|0)(?:51|50|55|70|77|99)[^\\d]{0,2}[2-9][0-9]{2}[^\\d]{0,2}[0-9]{2}[^\\d]{0,2}[0-9]{2}[^\\d]";
final String string = "\n"
+ "+994509793270\n"
+ "0509793270\n"
+ "+994708769006\n"
+ "0708769006\n"
+ "+994559793270\n"
+ "0559793270\n"
+ "+994519793270\n"
+ "0519793270\n"
+ "+994999793270\n"
+ "0999793270\n"
+ "+994779793270\n"
+ "0779793270\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}