// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)http://www\.xinhuanet\.com/yuqing/([0-9]*)-([0-9]*)/([0-9]*)/([a-z])_([0-9]*)\.htm").unwrap();
let string = "</li>
<li class=\"clearfix\">
<h3><a href=\"http://www.xinhuanet.com/yuqing/2015-10/25/c_128355180.htm\" target=\"_blank\">张志安:优秀微信公众号发展离不开这12个字</a></h3>
<i class=\"imgs\"><a href=\"http://www.xinhuanet.com/yuqing/2015-10/25/c_128355180.htm\" targrt=\"_blank\"><img class=\"lazyload\" src=\"http://www.news.cn/images2014/xh_load.gif\" data-original=\"\" /></a></i>
<p class=\"summary\">移动互联网的本质是通过便利的方式将内容连接起来,而优秀微信公众号正是用内容和服务在社群之间建立连接。回归一个起点,一个基本的逻辑,一个人有怎样的风格,这个人所带领的团队,所运营的微信公众号就有怎样的风格,风格是价值观的直接体现,也是这个公众号可持续发展的关键。</p>
<div class=\"info\">
<div class=\"bdsharebuttonbox clearfix\"> </div>
<span class=\"time\">2015-10-25</span>
</div>
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}