import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "http://www\\.xinhuanet\\.com/yuqing/([0-9]*)-([0-9]*)/([0-9]*)/([a-z])_([0-9]*)\\.htm";
final String string = "</li>\n"
+ "<li class=\"clearfix\">\n"
+ "<h3><a href=\"http://www.xinhuanet.com/yuqing/2015-10/25/c_128355180.htm\" target=\"_blank\">张志安:优秀微信公众号发展离不开这12个字</a></h3>\n"
+ "<i class=\"imgs\"><a href=\"http://www.xinhuanet.com/yuqing/2015-10/25/c_128355180.htm\" targrt=\"_blank\"><img class=\"lazyload\" src=\"http://www.news.cn/images2014/xh_load.gif\" data-original=\"\" /></a></i>\n"
+ "<p class=\"summary\">移动互联网的本质是通过便利的方式将内容连接起来,而优秀微信公众号正是用内容和服务在社群之间建立连接。回归一个起点,一个基本的逻辑,一个人有怎样的风格,这个人所带领的团队,所运营的微信公众号就有怎样的风格,风格是价值观的直接体现,也是这个公众号可持续发展的关键。</p>\n"
+ "<div class=\"info\">\n"
+ "<div class=\"bdsharebuttonbox clearfix\"> </div>\n"
+ "<span class=\"time\">2015-10-25</span>\n"
+ "</div>\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}