# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"http://www\.xinhuanet\.com/yuqing/([0-9]*)-([0-9]*)/([0-9]*)/([a-z])_([0-9]*)\.htm"
test_str = ("</li>\n"
"<li class=\"clearfix\">\n"
"<h3><a href=\"http://www.xinhuanet.com/yuqing/2015-10/25/c_128355180.htm\" target=\"_blank\">张志安:优秀微信公众号发展离不开这12个字</a></h3>\n"
"<i class=\"imgs\"><a href=\"http://www.xinhuanet.com/yuqing/2015-10/25/c_128355180.htm\" targrt=\"_blank\"><img class=\"lazyload\" src=\"http://www.news.cn/images2014/xh_load.gif\" data-original=\"\" /></a></i>\n"
"<p class=\"summary\">移动互联网的本质是通过便利的方式将内容连接起来,而优秀微信公众号正是用内容和服务在社群之间建立连接。回归一个起点,一个基本的逻辑,一个人有怎样的风格,这个人所带领的团队,所运营的微信公众号就有怎样的风格,风格是价值观的直接体现,也是这个公众号可持续发展的关键。</p>\n"
"<div class=\"info\">\n"
"<div class=\"bdsharebuttonbox clearfix\"> </div>\n"
"<span class=\"time\">2015-10-25</span>\n"
"</div>\n")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.