re = /\([+-]?(?!0)(\d)+(\.\d+)?,\s[+-]?(?!0)(\d)+(\.\d+)?\)/m
str = '(3420.34, 432)
(+342.32, 432)
(-342.5, 432)
(0342.23, 432)
(342., 432)
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end