import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\([+-]?(?!0)(\\d)+(\\.\\d+)?,\\s[+-]?(?!0)(\\d)+(\\.\\d+)?\\)";
final String string = "(3420.34, 432)\n"
+ "(+342.32, 432)\n"
+ "(-342.5, 432)\n"
+ "(0342.23, 432)\n"
+ "(342., 432)\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}