$re = '/\([+-]?(?!0)(\d)+(\.\d+)?,\s[+-]?(?!0)(\d)+(\.\d+)?\)/m';
$str = '(3420.34, 432)
(+342.32, 432)
(-342.5, 432)
(0342.23, 432)
(342., 432)
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);