$re = '/(.+).+[sS]?+([0-9]{1,2})+[eExX]+([0-9]{1,2})+.*\.(.+)$/';
$str = 'The.Great.British.Bake.Off.An.Extra.Slice.2x05.avi';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);