use strict;
my $str = 'The.Great.British.Bake.Off.An.Extra.Slice.2x05.avi';
my $regex = qr/(.+).+[sS]?+([0-9]{1,2})+[eExX]+([0-9]{1,2})+.*\.(.+)$/p;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}