using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(.+).+[sS]?+([0-9]{1,2})+[eExX]+([0-9]{1,2})+.*\.(.+)$";
string input = @"The.Great.British.Bake.Off.An.Extra.Slice.2x05.avi";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}