re = /CREATE\sTABLE\s([a-zA-Z0-9\`\_\-]{0,})/
str = 'CREATE TABLE `alarmas` ('
subst = ' $0 IF NOT EXISTS ('
result = str.sub(re, subst)
# Print the result of the substitution
puts result