$re = '/CREATE\sTABLE\s([a-zA-Z0-9\`\_\-]{0,})/';
$str = 'CREATE TABLE `alarmas` (';
$subst = " $0 IF NOT EXISTS (";
$result = preg_replace($re, $subst, $str, 1);
echo "The result of the substitution is ".$result;