const regex = /CREATE\sTABLE\s([a-zA-Z0-9\`\_\-]{0,})/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('CREATE\\sTABLE\\s([a-zA-Z0-9\\`\\_\\-]{0,})', '')
const str = `CREATE TABLE \`alarmas\` (`;
const subst = ` $0 IF NOT EXISTS (`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);