import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<(\\w*?)>";
final String string = "<soapenv:Envelope...>\n"
+ " <soapenv:Header/>\n"
+ " <soapenv:Body>\n"
+ " <urn:ClosedRequest>\n"
+ " <ExternalApplicationNumber>4816</ExternalApplicationNumber>\n"
+ " <PersonDataList>\n"
+ " <!--1 or more repetitions:-->\n"
+ " <PersonData>\n"
+ " <PersonExternalIdentifier>sa1</PersonExternalIdentifier>\n"
+ " <EligibilityEndDate>2017-12-31</EligibilityEndDate>\n"
+ " <!--Optional:-->\n"
+ " <ReasonCode>60</ReasonCode>\n"
+ " <PersonDeathDate>2015-09-02</PersonDeathDate>\n"
+ " </PersonData>\n"
+ " </PersonDataList>\n"
+ " </urn:ClosedRequest>\n"
+ " </soapenv:Body>\n"
+ "</soapenv:Envelope>";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}