#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "<(\w*?)>"
Local $sString = "<soapenv:Envelope...>" & @CRLF & _
" <soapenv:Header/>" & @CRLF & _
" <soapenv:Body>" & @CRLF & _
" <urn:ClosedRequest>" & @CRLF & _
" <ExternalApplicationNumber>4816</ExternalApplicationNumber>" & @CRLF & _
" <PersonDataList>" & @CRLF & _
" <!--1 or more repetitions:-->" & @CRLF & _
" <PersonData>" & @CRLF & _
" <PersonExternalIdentifier>sa1</PersonExternalIdentifier>" & @CRLF & _
" <EligibilityEndDate>2017-12-31</EligibilityEndDate>" & @CRLF & _
" <!--Optional:-->" & @CRLF & _
" <ReasonCode>60</ReasonCode>" & @CRLF & _
" <PersonDeathDate>2015-09-02</PersonDeathDate>" & @CRLF & _
" </PersonData>" & @CRLF & _
" </PersonDataList>" & @CRLF & _
" </urn:ClosedRequest>" & @CRLF & _
" </soapenv:Body>" & @CRLF & _
"</soapenv:Envelope>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")