package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`<(\w*?)>`)
var str = `<soapenv:Envelope...>
<soapenv:Header/>
<soapenv:Body>
<urn:ClosedRequest>
<ExternalApplicationNumber>4816</ExternalApplicationNumber>
<PersonDataList>
<!--1 or more repetitions:-->
<PersonData>
<PersonExternalIdentifier>sa1</PersonExternalIdentifier>
<EligibilityEndDate>2017-12-31</EligibilityEndDate>
<!--Optional:-->
<ReasonCode>60</ReasonCode>
<PersonDeathDate>2015-09-02</PersonDeathDate>
</PersonData>
</PersonDataList>
</urn:ClosedRequest>
</soapenv:Body>
</soapenv:Envelope>`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}