re = /(^\*$)|(.*\([^\)]*$)|(^[^\(]*\))|(.*\(\).*)|(^\s*(?:and|or)\s)|((?:and|or)\s*$)/
str = 'andftesting(sadggds) and g'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end