package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(^\*$)|(.*\([^\)]*$)|(^[^\(]*\))|(.*\(\).*)|(^\s*(?:and|or)\s)|((?:and|or)\s*$)`)
var str = `andftesting(sadggds) and g`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}