$re = '/(^\*$)|(.*\([^\)]*$)|(^[^\(]*\))|(.*\(\).*)|(^\s*(?:and|or)\s)|((?:and|or)\s*$)/';
$str = 'andftesting(sadggds) and g';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);