re = /^(?:http:\/\/|https:\/\/)?(?:www\.)?(?:imdb.com\/title\/)?(tt[0-9]*)/mi
str = 'http://www.imdb.com/title/tt2488496/?ref_=nv_sr_1
http://www.imdb.com/title/tt2488496/
https://www.imdb.com/title/tt2488496
imdb.com/title/tt2488496
tt2488496
imdb.com/title/season2488496
http://www.imdb.com/title/tt2488496
http://www.imdb.com/news/ni59315274
www.imdb.com/title/tt2488496/?ref_=nv_sr_1
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end