const regex = /^(?:http:\/\/|https:\/\/)?(?:www\.)?(?:imdb.com\/title\/)?(tt[0-9]*)/gmi;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(?:http:\\\/\\\/|https:\\\/\\\/)?(?:www\\.)?(?:imdb.com\\\/title\\\/)?(tt[0-9]*)', 'gmi')
const str = `http://www.imdb.com/title/tt2488496/?ref_=nv_sr_1
http://www.imdb.com/title/tt2488496/
https://www.imdb.com/title/tt2488496
imdb.com/title/tt2488496
tt2488496
imdb.com/title/season2488496
http://www.imdb.com/title/tt2488496
http://www.imdb.com/news/ni59315274
www.imdb.com/title/tt2488496/?ref_=nv_sr_1
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}