import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:http:\\/\\/|https:\\/\\/)?(?:www\\.)?(?:imdb.com\\/title\\/)?(tt[0-9]*)";
final String string = "http://www.imdb.com/title/tt2488496/?ref_=nv_sr_1\n"
+ "http://www.imdb.com/title/tt2488496/\n"
+ "https://www.imdb.com/title/tt2488496\n"
+ "imdb.com/title/tt2488496\n"
+ "tt2488496\n"
+ "imdb.com/title/season2488496\n"
+ "http://www.imdb.com/title/tt2488496\n"
+ "http://www.imdb.com/news/ni59315274\n"
+ "www.imdb.com/title/tt2488496/?ref_=nv_sr_1\n";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}