import Foundation
let pattern = #"\b(t(?:\w{4})\d{3})\b"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
SELECT tcmcs003.*, tccom130.nama, tccom705.dsca, tcmcs052.dsca, tccom100.nama
FROM tcmcs003, tccom130,tccom705,tcmcs052,tccom100
WHERE tcmcs003.cadr REFERS TO tccom130
AND tcmcs003.casi REFERS TO tccom705
AND tcmcs003.cprj REFERS TO tcmcs052
AND tcmcs003.bpid REFERS TO tccom100
ORDER BY tcmcs003._index1
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #"$1XXX"#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)