$re = '/\b(t(?:\w{4})\d{3})\b/';
$str = 'SELECT tcmcs003.*, tccom130.nama, tccom705.dsca, tcmcs052.dsca, tccom100.nama
FROM tcmcs003, tccom130,tccom705,tcmcs052,tccom100
WHERE tcmcs003.cadr REFERS TO tccom130
AND tcmcs003.casi REFERS TO tccom705
AND tcmcs003.cprj REFERS TO tcmcs052
AND tcmcs003.bpid REFERS TO tccom100
ORDER BY tcmcs003._index1';
$subst = "$1XXX";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;