const regex = /\b(t(?:\w{4})\d{3})\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\b(t(?:\\w{4})\\d{3})\\b', 'g')
const str = `SELECT tcmcs003.*, tccom130.nama, tccom705.dsca, tcmcs052.dsca, tccom100.nama
FROM tcmcs003, tccom130,tccom705,tcmcs052,tccom100
WHERE tcmcs003.cadr REFERS TO tccom130
AND tcmcs003.casi REFERS TO tccom705
AND tcmcs003.cprj REFERS TO tcmcs052
AND tcmcs003.bpid REFERS TO tccom100
ORDER BY tcmcs003._index1`;
const subst = `$1XXX`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);