// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)^[a-z0-9]*.(frm|MYI|MYD)$").unwrap();
let string = "AgeCategory.frm
agecategory.MYD
agecategory.MYI
agecategory.myd";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}