re = /^[a-z0-9]*.(frm|MYI|MYD)$/m
str = 'AgeCategory.frm
agecategory.MYD
agecategory.MYI
agecategory.myd'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end