$re = '/^[a-z0-9]*.(frm|MYI|MYD)$/m';
$str = 'AgeCategory.frm
agecategory.MYD
agecategory.MYI
agecategory.myd';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);