// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?m)(.*?),(,|\.)?").unwrap();
let string = "PL/SQL: Unit: ZIP_UTIL_PKG, type: PACKAGE BODY. Code Type: NATIVE. SVN: File date: $Date: 2019-08-26 10:28:11 -0500 $, Revision: $Revision: 18213 $, $Author: mark.s $.";
let substitution = "HEY ";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}