use strict;
my $str = 'PL/SQL: Unit: ZIP_UTIL_PKG, type: PACKAGE BODY. Code Type: NATIVE. SVN: File date: $Date: 2019-08-26 10:28:11 -0500 $, Revision: $Revision: 18213 $, $Author: mark.s $.';
my $regex = qr/(.*?),(,|\.)?/mp;
my $subst = 'HEY ';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";