# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(.*?),(,|\.)?/HEY /mg;t' <<< "PL/SQL: Unit: ZIP_UTIL_PKG, type: PACKAGE BODY. Code Type: NATIVE. SVN: File date: $Date: 2019-08-26 10:28:11 -0500 $, Revision: $Revision: 18213 $, $Author: mark.s $."