re = /((http|https|www)[^\s]+)|(@[^\s]+)|(#[^\s]+)/
str = 'En esta oficina: https://t.co/61sjPMbSHd '
# Print the match result
str.match(re) do |match|
puts match.to_s
end