package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`((http|https|www)[^\s]+)|(@[^\s]+)|(#[^\s]+)`)
var str = `En esta oficina: https://t.co/61sjPMbSHd `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}