$re = '/((http|https|www)[^\s]+)|(@[^\s]+)|(#[^\s]+)/';
$str = 'En esta oficina: https://t.co/61sjPMbSHd ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);