$re = '/ProcessChanges.*name=(.*)id=.*cardId=(\w+).*from (.*) -> (.*)/';
$str = '[Zone] ZoneChangeList.ProcessChanges() - id=33 local=False [name=Faceless Manipulator id=8 zone=HAND zonePos=0 cardId=EX1_564 player=1] zone from FRIENDLY DECK -> FRIENDLY HAND ';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);