package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`ProcessChanges.*name=(.*)id=.*cardId=(\w+).*from (.*) -> (.*)`)
var str = `[Zone] ZoneChangeList.ProcessChanges() - id=33 local=False [name=Faceless Manipulator id=8 zone=HAND zonePos=0 cardId=EX1_564 player=1] zone from FRIENDLY DECK -> FRIENDLY HAND `
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}