const regex = /ProcessChanges.*name=(.*)id=.*cardId=(\w+).*from (.*) -> (.*)/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('ProcessChanges.*name=(.*)id=.*cardId=(\\w+).*from (.*) -> (.*)', '')
const str = `[Zone] ZoneChangeList.ProcessChanges() - id=33 local=False [name=Faceless Manipulator id=8 zone=HAND zonePos=0 cardId=EX1_564 player=1] zone from FRIENDLY DECK -> FRIENDLY HAND `;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}