$re = '/^(\w+\@[a-zA-Z]+\.[a-zA-Z]{2,3}\,?)+$/';
$str = 'a15bc@gmail.coM,AAAA@gmail.cOM,BBC@KHKJ.COM';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);