#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^(\w+\@[a-zA-Z]+\.[a-zA-Z]{2,3}\,?)+$"
Local $sString = "a15bc@gmail.coM,AAAA@gmail.cOM,BBC@KHKJ.COM"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")