package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^(\w+\@[a-zA-Z]+\.[a-zA-Z]{2,3}\,?)+$`)
var str = `a15bc@gmail.coM,AAAA@gmail.cOM,BBC@KHKJ.COM`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}