$re = '/^(?:[[:alpha:]]|[ \-\'])+$/mui';
$str = 'Alexander
Musin-Pushkin
D\'Artagnan
Александр
Тёркин
François
Maček
José
Jürgen
Жан жак
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);