package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^(?:[[:alpha:]]|[ \-\'])+$`)
var str = `Alexander
Musin-Pushkin
D'Artagnan
Александр
Тёркин
François
Maček
José
Jürgen
Жан жак
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}